Sign up or log in for full site functionality and to hide this notice.

Join to the community in order to comment, like, post images, videos and create threads.

:)

Sink between board and controller issue

Discussion in 'General Eskate Chat' started by Altabum, Jun 23, 2019.

More threads by Altabum
  1. Altabum

    Altabum Member

    Have a year old Carbon GT. Ride 4-5 times a week. Lately when controller hooks up with board it will not let me adjust above ECO. Usually always starts up showing fast and with one click goes to GT. Now shows fast but won’t adjust pass Eco. Fully charged. Board and handset. Need advice.
     
  2. Kaup30

    Kaup30 Member

    Had this happen to me on my GTX.. take the battery cover off and look for the uart cable (google search will show you where to look).. I had been riding 97s for a few weeks on sidewalks, and my battery shifted from vibration pinching the uart connection. Check it out, might just do the trick
     
  3. David

    David Member

    Same issue with my Carbon GT All terrain.Evolve sent me an e-mail with detailed instructions on how to fix. Seems to have solved my problem like your having. Have'nt taken for a test ride yet.
     
  4. markm

    markm Member

    same issue, brake switch wasnt returning to off, it was sticking causing the issue, also had other issues in settings, make sure your v2 not v1
    also i accidnentally altered my Brake Pol to - as it should be on +, this was another issue but setting to + fixed it
     
Loading...

Share This Page