1. Bamboo Series
Sign up or log in for full site functionality and to hide this notice.

Join to the community in order to comment, like, post images, videos and create threads.

:)

Power button not lighting up

Discussion in 'Bamboo GT' started by Janick, Nov 23, 2016.

Tags:
More threads by Janick
  1. Janick

    Janick Member

    Joined:
    Oct 25, 2016
    Messages:
    11
    Likes Received:
    2
    Location:
    Singapore
    Real Name:
    Carl
    Map
    hi guys. I got my bamboo gt yesterday and I rode for about 30 Kms with the street setup with still 50%+ battery left (surprising) but today when I try to turn it on the light won't come on no matter what. I opened it up and can't seem to find any loose wires or burnt out circuitry or any moisture for that matter. I charged it immediatedly after my trip yesterday and it still had over 80 percent battery when I checked it last night so I just plugged it in and left it charging overnight. I emailed evolve and they said they would send a replacement switch for me to try out but that could take some time. Any suggestions on what could be the problem so I can try to fix it in the meantime?
     
  2. Andy

    Andy Mod

    Joined:
    Sep 19, 2016
    Messages:
    509
    Likes Received:
    418
    Location:
    Welling, England, GB
    Real Name:
    Andy Smith
    Boards Owned:
    Carbon GT, Bamboo GT, Bamboo (Gen 2), Bustin Pintail (Gen 2), Bustin Mission (Gen 2), Bamboo Pintail (Gen 1)
    Wheel Setup:
    Street & AT
    Wheel Size:
    175
    Map
    Hmm will it switch on when plugged into charger?
     
  3. OP
    Janick

    Janick Member

    Joined:
    Oct 25, 2016
    Messages:
    11
    Likes Received:
    2
    Location:
    Singapore
    Real Name:
    Carl
    Map
    It won't. The charger shows green and I'm pretty sure it's fully charged.
     
  4. paulfulwood

    paulfulwood Member

    Joined:
    Oct 6, 2016
    Messages:
    172
    Likes Received:
    114
    Location:
    Marsh Ave, Manning, Western Australia, Australia
    Real Name:
    Paul Fulwood
    Boards Owned:
    Carbon GT
    Wheel Setup:
    Street & AT
    Wheel Size:
    200
    Map
    Does it flash blue two times when you turn the switch off? Did you charge it with the power button on?
    I have also experienced this regularly. It usually either needs mutiple on off presses or be left in the off position for an amount of time and then it just starts working, Evolve fairy comes in and fixes it I think.
    Did yours end up coming back on, I see you posted this yesterday
     
  5. OP
    Janick

    Janick Member

    Joined:
    Oct 25, 2016
    Messages:
    11
    Likes Received:
    2
    Location:
    Singapore
    Real Name:
    Carl
    Map
    I think I charged it with the power button on. How do I fix that?
     
  6. OP
    Janick

    Janick Member

    Joined:
    Oct 25, 2016
    Messages:
    11
    Likes Received:
    2
    Location:
    Singapore
    Real Name:
    Carl
    Map
    And no it hasn't come on sadly since the day before :(. No lights come on at All
     
  7. OP
    Janick

    Janick Member

    Joined:
    Oct 25, 2016
    Messages:
    11
    Likes Received:
    2
    Location:
    Singapore
    Real Name:
    Carl
    Map
    Update: I tried on the new switch but it still doesn't work. Now I have to ship it back to evolve to fix it and that's gonna mean a lot of downtime for me :(
     
  8. paulfulwood

    paulfulwood Member

    Joined:
    Oct 6, 2016
    Messages:
    172
    Likes Received:
    114
    Location:
    Marsh Ave, Manning, Western Australia, Australia
    Real Name:
    Paul Fulwood
    Boards Owned:
    Carbon GT
    Wheel Setup:
    Street & AT
    Wheel Size:
    200
    Map
    Disconnect the battery power and all cables to motor controller first. Then replug all back in. At least try it before you send it.
    I always have a rule now to turn off board then turn off remote. The Auto Power off thing I think is a problematic for some. And definitely off when charging
     
  9. OP
    Janick

    Janick Member

    Joined:
    Oct 25, 2016
    Messages:
    11
    Likes Received:
    2
    Location:
    Singapore
    Real Name:
    Carl
    Map
    Yeah I tried everything... Brian at evolveskateboards Asia said he would send me a motor controller and power port to try out first. If all fails then I have to send it back. Do u think it might have something to do with the bms or battery?
    btw what's the auto power off thing?
     
  10. paulfulwood

    paulfulwood Member

    Joined:
    Oct 6, 2016
    Messages:
    172
    Likes Received:
    114
    Location:
    Marsh Ave, Manning, Western Australia, Australia
    Real Name:
    Paul Fulwood
    Boards Owned:
    Carbon GT
    Wheel Setup:
    Street & AT
    Wheel Size:
    200
    Map
    If you leave the board on it turns itself off after time. I have two boards. One is fine with turning back on after auto power off, the other isn't. Not 100℅ sure if it's the bms or motor controller, so not worth commenting it.
     
  11. julian46

    julian46 Member

    Joined:
    Nov 14, 2016
    Messages:
    251
    Likes Received:
    101
    Location:
    Toronto, ON, Canada
    Real Name:
    Julian
    Boards Owned:
    Bamboo GT
    Wheel Setup:
    Street
    Wheel Size:
    83
    Map
    What's the normal behavior for the power button blue light ? I thought mine kept blinking the whole time it was on - will check again and repost.
     
  12. julian46

    julian46 Member

    Joined:
    Nov 14, 2016
    Messages:
    251
    Likes Received:
    101
    Location:
    Toronto, ON, Canada
    Real Name:
    Julian
    Boards Owned:
    Bamboo GT
    Wheel Setup:
    Street
    Wheel Size:
    83
    Map
    yea the blue light on my power switch blinks continuously when on
     
  13. OP
    Janick

    Janick Member

    Joined:
    Oct 25, 2016
    Messages:
    11
    Likes Received:
    2
    Location:
    Singapore
    Real Name:
    Carl
    Map
    Blinking is normal when it's on.
     
    • Useful Useful x 1
  14. Jremawsm

    Jremawsm Member

    Joined:
    Nov 12, 2016
    Messages:
    1
    Likes Received:
    0
    Location:
    Houston, TX, United States
    Real Name:
    Jeremy
    Boards Owned:
    Bamboo GT
    Wheel Setup:
    All Terrain (AT)
    Map
    Is there any update on what you ended up doing to fix your board? My girlfriend did something to mine yesterday and now the power button doesn't light up on the board. I just want to know if this is fixable at home or should I send it in to evolve ASAP.
     
  15. Alex

    Alex Admin

    Joined:
    Sep 9, 2016
    Messages:
    1,554
    Likes Received:
    968
    Location:
    Barnes, London, United Kingdom
    Real Name:
    Alex Jermstad
    Boards Owned:
    Carbon
    Wheel Setup:
    All Terrain (AT)
    Map
    Jremawsm, You might have better luck if you tag Janick, as the notification will be more personal. I've tagged him just now in this post.
     
    • Like Like x 1
  16. dadawg

    dadawg Member

    Joined:
    Dec 5, 2016
    Messages:
    40
    Likes Received:
    22
    Location:
    Blanchardstown, Ireland
    Real Name:
    David O Gara
    Boards Owned:
    I don't have one yet :(
    Wheel Setup:
    Street & AT
    Map
    Hey,

    Any update on your problem with the board Janick?
     
    • Like Like x 1
  17. OP
    Janick

    Janick Member

    Joined:
    Oct 25, 2016
    Messages:
    11
    Likes Received:
    2
    Location:
    Singapore
    Real Name:
    Carl
    Map
    Sorry I didnt see all the replies, evolve sent me a new motor controller and its all good now :)
     
    • Like Like x 2
    • Love Love x 1
  18. dadawg

    dadawg Member

    Joined:
    Dec 5, 2016
    Messages:
    40
    Likes Received:
    22
    Location:
    Blanchardstown, Ireland
    Real Name:
    David O Gara
    Boards Owned:
    I don't have one yet :(
    Wheel Setup:
    Street & AT
    Map
    I may have to do the same :(
     
  19. Eddy506

    Eddy506 Member

    Joined:
    Apr 19, 2017
    Messages:
    3
    Likes Received:
    0
    Location:
    Canary Islands, Spain
    Real Name:
    Eddy Estevez
    Boards Owned:
    Carbon GT, Carbon, Bamboo (Gen 2)
    Wheel Setup:
    Street & AT
    Map
    Same trouble , just charged my board Carbon Gt and it does not switch on . No power , no blue light . I start to feel quite scared ... pleAse any help
     
  20. Obie1

    Obie1 Member

    Joined:
    Jan 21, 2017
    Messages:
    28
    Likes Received:
    36
    Location:
    Brisbane, Griffin, Queensland, Australia
    Real Name:
    Neil
    Boards Owned:
    Carbon GT
    Wheel Setup:
    All Terrain (AT)
    Wheel Size:
    175
    Map
    Just found this thread after having to walk to work this morning carrying my gear and board. Same thing no power on to my board, no blue light on the power button. My board had done 1,800km with no issues with this at least. I have found a solution for my board and work ok now. When I got home I took the cover off and simply power cycled the battery by unplugging it from the battery end. I waited around 20 sec to make sure there was no residual charged left and plugged it back in. The board then powered on as normal. Of course this won't be for everyone It could be various causes. Hope this helps someone.

    Cheers.
     
Loading...

Share This Page