Sign up or log in for full site functionality and to hide this notice.

Join to the community in order to comment, like, post images, videos and create threads.

:)

Evolve Suggestion Only white screen when pressing power button on remote

Discussion in 'Evolve Ideas & Suggestions' started by ToobzCarb, Nov 19, 2017.

Tags:
More threads by ToobzCarb
  1. ToobzCarb

    ToobzCarb Member

    hi, I have recently received a brand new gt remote, how ever when I press the power button only a white screen comes on with no evolve logo and doesn't continue to the normal display of speedo, trip metre etc... has anyone had this problem and overcome it. Thank you.
     
  2. fbhb

    fbhb Member

    I think I can recall someone having success by opening up the remote, disconnecting the battery & then re-connecting the battery. There is of course no guarantee that this will work for you too, but it is only four screws so it's worth a try! Failing that, if you only just got the remote you should really contact Evolve anyway.
     
  3. OP
    ToobzCarb

    ToobzCarb Member

    Yea cheers... I tried that straight away with no luck... be giving evolve a call tomorrow... thanx again!!
     
  4. dontaskwhy

    dontaskwhy Member

    had this problem with the prev gen remote
    fixed after charging it for the night

    IMG-20180712-WA0005.jpg
     
Loading...
Similar Threads - white screen pressing
  1. CTOWNS BBQ
    Replies:
    4
    Views:
    836
  2. sirwolf
    Replies:
    1
    Views:
    225

Share This Page