Sign up or log in for full site functionality and to hide this notice.

Join to the community in order to comment, like, post images, videos and create threads.

:)

Brand new board power button won’t turn on

Discussion in 'Bamboo GTX' started by Adair0, Dec 6, 2018.

Tags:
  1. Adair0

    Adair0 Member

    bought the board today, turned on paired and plugged in to do full charge before the first run. Thought it was weird after an hour+ that it still hasn’t finished the last 15% and was a red light. Tried to turn on and it just did nothing.
    No blue light flashing.
    Tried leaving for an hour. Holding power button, seeing if it was just the LED that had failed but seems it’s not working st all. Disconnected power cable etc and left for a while but still won’t turn on.
     
  2. OP
    Adair0

    Adair0 Member

    Suddenly started working again after leaving everyone unplugged and off for a few hours
     
  3. walterafable

    walterafable Member

    An hour plus? A full battery charge will take almost four hours. Don't get in the habit of prematurely unplugging the charger before the light goes green. You'll degrade the battery cells!
     
  4. Stefan

    Stefan Member

    You may have to resolder some connections soon. It may get worse and worse..
    I had the same problem and after some checking I found some of the wires in the connectors to the BMS and powerbutton got loose.

    If you keep having these issues open the cover and check for any loose wires.
     
Loading...

Share This Page